Wins Security Information

취약점 정보

앞 내용 보기 다음 내용 보기
취약점 정보[CVE-2021-24389] WP Theme FoodBakery XSS
작성일 2021-08-06 조회 43

 

 

WordPress Theme FoodBakery에 XSS (Cross Site Scripting) 취약점이 존재합니다.

 

해당 취약점은 /listing/ 경로의 foodbakery_radius 매개변수에 대한 사용자 입력의 유효성 검사가 불충분하여 발생합니다. 원격의 공격자는 악의적으로 조작된 요청을 전송하여 공격할 수 있습니다.

 

공격 성공 시, 임의의 코드가 실행될 수 있습니다.

 

 

 

취약점 설명

 

NVD - CVE-2021-24389

CVSS v2.0 Severity and Metrics:

Base Score: 4.3 MEDIUM

 

 

[그림1. NVD 내역]

 

 

 

취약점 분석

 

 

해당 취약점은 /listings/ 경로의 foodbakery_radius 매개변수에서 사용자 입력값을 제대로 검증하지 않아 발생합니다. 임의의 공격자는 해당 취약점을 이용하기 위해 foodbakery_radius 매개변수에 ", </ , > 와 같은 문자를 삽입하여 공격할 수 있습니다.

취약한 버전은 2.1 이하의 버전이며, 2.2 버전에서 해당 취약점이 패치되었습니다.

 

 

공격 분석

 

 

CVE-2021-24389의 공격 패킷은 다음과 같습니다.

 

 

[그림 3. 공격 패킷]

 

 

공격 성공 시, 임의의 코드가 실행될 유출될 수 있습니다.

 

 

 

취약점 대응 방안

 

1. 최신 버전 사용

 

해당 벤더사에서 발표한 최신의 버전으로 업데이트한다.

https://themeforest.net/item/food-bakery-restaurant-bakery-responsive-wordpress-theme/18970331

 

 

2. WINS Sniper 제품군 대응 방안

 

[5581] WordPress Theme FoodBakery foodbakery_radius XSS

 

첨부파일 첨부파일이 없습니다.
태그 CVE-2021-24389  WordPress  FoodBakery