Wins Security Information

보안 정보

앞 내용 보기 다음 내용 보기
취약점 정보[CVE-2020-17496] vBulletin RCE
작성일 2021-01-04 조회 1646

vBulletin - Home | Facebook

 

 

vBulletin에 원격 코드 실행 취약점이 존재합니다.

 

해당 취약점은 widget_tabbedcontainer_tab_panel의 잘못된 입력 유효성 검사로 인해 발생합니다. 

 

원격의 공격자는 특수하게 조작된 HTTP body에 PHP 코드가 포함된 구문을 전송하여 공격할 수 있습니다.

 

공격 성공 시, 임의의 코드가 실행될 수 있습니다.

 

 

 

취약점 설명

NVD - CVE-2020-17496

Base Score: 7.5 MEDIUM

 

 

[그림1. NVD 내역]

 

 

 

취약점 분석

 

해당 취약점은 CVE-2019-16759에 대한 조치를 우회하여 나타났으며,  vBulletin 템플릿 시스템의 구조화로 인해 발생합니다.

 

"widget_tabbedcontainer_tab_panel"은 다음 두 가지 기능으로 인해 이전 CVE-2019-16759패치를 우회할 수 있습니다.

 

1. 사용자 제어 하위 템플릿을 로드하는 템플릿 기능

2. 템플릿이 변수로부터 값을 가져와 widgetConfig에 입력하여 자식 템플릿을 로드

 

 

취약한 버전은 5.5.4 ~ 5.6.2 버전이며, 제조사는 해당 취약점을 패치한 후 업데이트를 공개하였습니다.

 

[그림 2. 공격 패킷]

 

 

 

 

취약점 대응 방

 

1. 최신 버전 사용

 

해당 벤더사가 발표한 보안 권고문을 참고하여 최신의 버전으로 업데이트한다.

https://forum.vbulletin.com/forum/vbulletin-announcements/vbulletin-announcements_aa/4445227-vbulletin-5-6-0-5-6-1-5-6-2-security-patch

 

 

2. WINS Sniper 제품군 대응 방안

 

vBulletin widget_tabbedcontainer_tab_panel RCE.A

 

 

 

첨부파일 첨부파일이 없습니다.
태그 CVE-2020-17496