Wins blog

글로벌 정보보안 파트너! Global Security  No.1 윈스는 국가대표 정보보안 기업에서 글로벌 강소기업으로 도약합니다.

보안 정보

앞 내용 보기 다음 내용 보기
취약점 정보[CVE-2020-25790] Typesetter CMS 파일 업로드 취약점
작성일 2020-10-30 조회 85

 
 
Typesetter CMS에 파일 업로드 취약점이 존재합니다.
 
Typesetter CMS는 PHP를 사용하여 개발된 무료 오픈 소스 컨텐츠 관리 시스템으로, 데이터베이스가 없어 쉽고 빠르게 이용할 수 있습니다.
 
해당 취약점은 사용자가 업로드한 파일에 대한 부적절한 제한으로 인해 발생합니다. 원격의 공격자는 악의적으로 조작된 파일을 업로드하여 공격할 수 있습니다.
 
공격 성공 시, 임의의 코드가 실행될 수 있습니다.

 

 

 

취약점 설명

 

NVD - CVE-2020-25790

CVSS v2.0 Severity and Metrics:

Base Score: 6.5 MEDIUM

 

 

[그림1. NVD 내역]

 

 

취약점 분석

 

해당 취약점은 업로드한 파일에 대한 부적절한 업로드 제한으로 인해 발생합니다.

 

Typesetter CMS에 관리자 권한으로 접속하여 zip 아카이브 내의 .php파일을 통해 임의의 PHP코드를 업로드하고 실행할 수 있습니다.

 

취약한 버전은 5.1이며, 관리자는 신뢰할 수 있는 것으로 간주하여 패치는 없을 것으로 보입니다.

 

 

공격 분석 및 테스트

 

CVE-2020-25790에서 탐지되는 패킷은 다음과 같습니다.

 

업로드한 zip 아카이브 내의 .php파일의 압축을 풀면 임의의 코드를 실행할 수 있습니다.

 

 

[그림2. 'id' 명령문 실행 결과]

 

[그림3. 공격 패킷]

 

 


취약점 대응 방안

 

1. 최신 버전 사용

 

해당 벤더사에서 발표한 보안 권고문을 참고하여 패치를 적용합니다.

https://github.com/Typesetter/Typesetter

 

첨부파일 첨부파일이 없습니다.
태그 CVE-2020-25790  Typesetter CMS File Upload